Winbook TW700 is not turning on at all

Questions on the new Winbook Tablets? Post them here!

Winbook TW700 is not turning on at all

Postby juancanic » 27 Jan 2015 16:58

my Tablet was working fine by several days but today is not turning on. I requested support via chat and after some tests, they suggested me bring it to a store for replacement. but now I am outside USA, so I decided open it with my nails it the borders (very easy to open) then I removed the battery and after 1 minute I reconnect it and now it is working fine again.
I write this in case anyone else has a similar problem. :)
juancanic
 
Posts: 1
Joined: 27 Jan 2015 16:46

Re: Winbook TW700 is not turning on at all

Postby CalBear » 29 Jan 2015 16:42

You probably did a "reset" by disconnecting the battery. On the TW100 there is a reset "button" that you activate using a pin or un-bent paper clip. My wife's TW100 sometimes won't turn on and that "fixes" the problem. I have not had the same problem with mine.
CalBear
 
Posts: 21
Joined: 20 Oct 2014 00:44

Re: Winbook TW700 is not turning on at all

Postby Rewind » 08 Feb 2015 10:23

Took me a bit to figure out where to start with trying to open the case, but this worked for me as well.

I used my fingernail along the long edge of the tablet. There is a very thin line that separates the front and back of the case (for reference, the power / volume buttons are part of the front of the case, the rear is on the other side of the thin line); by running your nail down the middle of the edge and applying some pressure you should be able to feel a space between some clips. Insert your nail carefully and then slide it in either direction and you should be able to get the clips to pop. Work your way along the entire side you started on, along the bottom of the tablet, and then up the other long side leaving the top for last. Once the two sides and bottom are released, open the back cover using the top like a hinge and swing the back cover away from the usb/audio ports.

You will see a thin foil like heat sink and the battery is underneath. You don't need to pull the battery itself out, just disconnect it from the main board. There is a single connector with 5 wires along one side with a couple of red / white / and black wires. Just gently pull up on that connection and it should release without too much effort. Wait a minute, re-seat the connection, and hopefully your tablet will come back to life (mine did). You can test the power button to see if it comes to life while the back is still open but I HIGHLY recommend AGAINST that for fear something else could drop into it and short something out.

Reattach the back cover by fit-ting (for some reason the MC forum sees "f i t t i n g" as a dirty "w o r d" (really, "w o r d" gets replaced too?)) the back panel over the ports on the top of the tablet first, close it like a hinge, make sure it is fairly well lined up, and gently squeeze the cover back together.
MicroCenter Technician: Dec 1999 - April 2001
Rewind
 
Posts: 1
Joined: 08 Feb 2015 10:09

Re: Winbook TW700 is not turning on at all

Postby Billgonzo » 18 Mar 2015 19:14

Thank you guys so much for posting this. This is the only place on the web that has any info about opening the TW700...I just opened mine because I was getting a black screen and couldnt boot. I unplugged the battery and the LCD ribbon and now my tablet is in working order.

Thanks!
Billgonzo
 
Posts: 8
Joined: 18 Mar 2015 17:45

Re: Winbook TW700 is not turning on at all

Postby 92 NSX » 29 Mar 2015 02:18

This is super helpful! Had the same issue, but did not open the tablet. Basically, the tablet was sitting uncharged for a couple of days, and then it started right back up! The battery was fully discharged. I may have installed some software that may have freezed up the tablet. I think they should include this troubleshooting in the manual in case anyone else has the same issue.
92 NSX
 
Posts: 2
Joined: 29 Mar 2015 02:14

Re: Winbook TW700 is not turning on at all

Postby Moonrocker » 25 Jun 2015 20:43

I got my TW700 and give it as s gift for my daughter, it has the same problem. No power and display, luckily I was able to read this thread and last night, my daughter and I, tried it, it works and my daughter was so glad her TW700 is back online. Thank you for sharing.
Moonrocker
 
Posts: 1
Joined: 25 Jun 2015 20:39

Re: Winbook TW700 is not turning on at all

Postby EvMerritt » 05 Aug 2015 13:21

Ref comments by CalBear on reset switch on TW100

I just posted a request for where that switch was, and exactly what it did. Only response was one that said I was wrong, there was no such switch.

I think its the small hole on top next to the Volume Controls (to put a paper clip in). Is this right? ... and what other than resetting battery(?) do you think it does?

Please answer here or in that post directly on the Reset subject. Thanks, Ev Merritt

This is the post header:

TW100 Reset "Hole" - Where and what does it do?
by EvMerritt » 05 Aug 2015 09:49
EvMerritt
 
Posts: 5
Joined: 06 Jan 2015 13:46

Re: Winbook TW700 is not turning on at all

Postby othercents » 05 Aug 2015 14:59

EvMerritt wrote:
> I think its the small hole on top next to the Volume Controls (to put a
> paper clip in). Is this right? ... and what other than resetting battery(?)
> do you think it does?

I always thought that was a microphone. Do we not have a microphone? I don't see any other holes other than the speaker ones on the back.
othercents
 
Posts: 17
Joined: 01 Aug 2015 13:59

Re: Winbook TW700 is not turning on at all

Postby EvMerritt » 05 Aug 2015 15:47

Ref: othercents

Its TINY. Only big enough for a paper clip. That's why I thought it might be a reset "button". That's what some other electronic devices have. Mine has a real mic socket on right edge below SD card slot.

-Ev Merritt
EvMerritt
 
Posts: 5
Joined: 06 Jan 2015 13:46

Re: Winbook TW700 is not turning on at all

Postby broncus » 06 Aug 2015 10:14

Greetings,

My USB connector had a contact pealed back inside the connector housing. It needs a new USB connector. I am now off to find a proper replacement.

Since my TW700 won't turn on now either. I figured I would open it up and disconnect/connect the battery. After opening the case, I was looking around with an eye loop and saw that one of the contacts in the USB connector (power in) was peeled back. Now I know why it wasn't turning on. The battery would charge for a bit then it would loose connection and never really charge the battery.

Best regards,
Fred
broncus
 
Posts: 6
Joined: 06 Aug 2015 09:54

Next

Return to WinBook Tablets

Who is online

Users browsing this forum: No registered users and 6 guests